Saturday, 18 April 2015

Wrong Google Play Services? Fix from experience

I did not know how to update Google Play Services. I installed the wrong version. You must go to the Application manager and see what version you need. For example my Note 4, needs a .430 version. My HTC needs a .448 version. So whatever version is the update has to be 7.3.26, with your version number at the end.

See www.apkmirror.com
If you have installed the wrong version and no Google app will open you need to go back to the Application Manager and find Google Play Services and pick Uninstall Updates. You will find it will all function again.

No comments:

Post a comment